Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted 10 days ago. Mar 22, 2025 - 05:00 UTC
Scheduled
We wanted to let you know that Factorial will undergo scheduled maintenance on March 22nd between 6:00 and 7:00 (CET). During this time, both the mobile app and web platform will be temporarily unavailable.
We’re updating security patches and improving performance to ensure you have the best service possible. We apologize for any inconvenience and appreciate your understanding as we work to keep everything running smoothly.
If you have any questions or need assistance, feel free to reach out to our support team.
Best, The Factorial Team
Posted 12 days ago. Mar 19, 2025 - 16:37 UTC
This scheduled maintenance affected: Factorial API, app.factorialhr.com, and Webpage.