Performance issue

Incident Report for Factorial

Resolved

The problem has been resolved. We apologize for the inconvenience this may have caused and hope you have a great day ahead!
Posted Sep 23, 2025 - 08:03 UTC

Monitoring

The fix has been deployed and we are seeing better performance metrics across the application.
Posted Sep 23, 2025 - 07:54 UTC

Update

The fix has been identified and is being deployed.
Posted Sep 23, 2025 - 07:29 UTC

Identified

Our monitoring systems have detected a degradation in the application performance - some pages might take longer to render or even time out. We have identified the faulty component and are investigating a possible fix.
Posted Sep 23, 2025 - 07:24 UTC
This incident affected: app.factorialhr.com (Factorial website).