Issue refreshing advanced reports

Incident Report for Factorial

Resolved

This incident has been resolved.
Posted Feb 19, 2026 - 22:16 UTC

Monitoring

Our efforts have mitigated the data refresh issue in Advanced Reports. We keep tuning the platform to recover full functionality on this feature during the day.
Posted Feb 19, 2026 - 08:29 UTC

Identified

We are currently experiencing an issue affecting the Advanced Reports module, causing delays in data refresh and, in some cases, preventing reports from loading.
Posted Feb 18, 2026 - 16:17 UTC
This incident affected: app.factorialhr.com (Factorial website).