Degraded latency and increased error rates - failing cache system

Incident Report for Factorial

Resolved

We have identified the root of the problem and have deployed fixes to restore the service performance.
We apologize for the inconvenience caused.
Posted Apr 24, 2025 - 14:28 UTC

Investigating

We are investigating an issue where one of our cache nodes has become unresponsive, leading to a global performance degradation. We are working on restoring the service as soon as possible.
Posted Apr 24, 2025 - 14:03 UTC
This incident affected: Factorial API and app.factorialhr.com.